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Changes made with Version 1.1

· Average calculations for sub-elements were not correctly calculated.   Changes made to correctly weight calculations based upon number of evaluation criteria.
· Hyperlinks added to Summary Sheet to quickly link to evaluate or assess problem areas.
· Relaxed some of the protection on some entry fields to alleviate the need to take protection of the worksheet every time a change is needed.






1. introduction

1.1 Background

Managing risk during the transition from development to production is a critical task in the life cycle of Air Force programs.  This singular topic has been the subject of many articles, regulations, pamphlets, and guides, of which only a small handful are listed in Section 2 of this document.   The PRR Tool attempts to provide a mechanism to assist in the planning, execution and evaluation of one of the risk management tools employed by Air Force program offices and their contractors to assess and manage risk during this important transition period: the Production Readiness Review (PRR).

1.2 Purpose

The PRR Tool described in this document provides a Microsoft® Excel workbook containing a set of Microsoft® Excel spreadsheets that can be configured and used to organize a Production Readiness Review (PRR) and to gather and present the results.

1.3 Scope

This document provides high-level guidance on the assumptions, features, and use of the PRR Tool, Version 1.10.  The template filename is ASC_PRR_Tool_Version1_10.xls. It was produced using Microsoft® Excel 2003.  While the tool has not been tested on later versions, it is expected to be compatible with later versions.  There may be some limitations when using this tool in earlier versions.  The current version of this tool has not been tested with earlier versions of Excel.   
1.4 Document Overview

Section 1 of this document provides introductory material.  Section 2 lists referenced documents.  Section 3 describes the PRR Tool features.  Section 4 provides a glossary of terms whose usage implies specific meanings within the context of this document.

2. Referenced Documents

1. DOD 4245.7-M, Transition from Development to Production, Department of Defense, September 1985.

2. AFSC Regulation 84-2, Production Readiness Review, Department of the Air Force, Headquarters Air Force Systems Command, 19 September 1986.

3. ASD Pamphlet 84-3, Manufacturing Management/Production Capability Reviews and Production Readiness Reviews, Department of the Air Force, Headquarters, Aeronautical Systems Division (AFSC), 5 March 1976.

4. Manufacturing Development Guide, Aeronautical Systems Center Engineering Directorate, January 2004.

3. Tool Features

3.1 Cell Protection

The PRR Tool employs cell protection as a means of limiting accidental editing of fields, formats, and formulas that should be left static.  It is invoked and revoked by selecting Tools -> Protection -> Protect Sheet.  No password has been employed by the developer (i.e., the password field has been completely left blank when invoked).  When sheet-level protection is invoked, cells tagged as “locked” can not be edited; cells not so tagged can be.  Sheet-level protection is revoked by selecting Tools -> Protection -> Unprotect Sheet.  

Care should be taken when taking the protection off of the tool’s individual sheets.  Do so only when editing of Sub Elements is desired.  Once edited, the sheet’s protection should be re-invoked.  Since sheet protection does not protect cells that have been specified as unprotected, the fields that users should edit during the conduct of the PRR are available for editing even with sheet-level protection invoked.  This should be the default mode when the PRR Tool is deployed in support of a specific PRR.

Tool Tip: It is recommended that the ASC_PRR_Tool_Version1_10.xls file be renamed to a more meaningful name upon the onset of a specific PRR.  For example, F-99_PRR_Results.xls.

3.2 Admin Tab

The PRR Tool allows a PRR to be topically divided among up to 4 separate review teams.  The default organization was intentionally designed to describe very high level categories.  This allows for some logical placement of PRR topics presented in a variety of published sources, including DOD 4245.7-M, Transition from Development to Production (also known as the “Willoughby Templates”) [1], AFSCR 84-2, Production Readiness Reviews [2], ASD Pamphlet 84-3, Manufacturing Management/Production Capability Reviews and Production Readiness Reviews [3], and the Manufacturing Development Guide [4].

The first tab of the spreadsheet captures identifying information about the PRR being conducted and presents the four PRR Major Elements: (1) Manufacturing Management, (2) Manufacturing Engineering, (3) Manufacturing Operations, and (4) Product Assurance.  Each Major Element has a separate tab that may possess up to ten Sub Elements.  Each Sub Element may possess up to ten Evaluation Elements.  The tool therefore allows for up to 100 individual Evaluation Elements per Major Element, for a total of 400 Evaluation Elements.

Major Element ( 10 Sub Elements ( 10 Evaluation Elements

The editable fields on the Admin Tab are displayed in light yellow and include Government PMO, Contractor, Product, Review Start Date, Review End Date, and Out-brief Date. The Government PMO, Contractor, and Product entries often carry forward to Evaluation Elements on the individual Major Element Tabs (as described in Section 3.4.2). The Sub Elements, on the other hand, are brought back from the Major Element Tabs.  If the review team elects to edit Sub Element titles on the Major Element Tabs, those edits will be reflected here.

Usability Tip: Pressing the TAB key, rather than the arrow keys, will provide users the capability to navigate through only those fields on a give screen that are unprotected (i.e., user editable).  TAB will move the cursor from field to field employing a left to right, top to bottom pattern.

3.3 Risk Thresholds Tab

The data collection/out-brief portion of the tool provides users the ability to record for each Evaluation Element a risk rating.  To provide individual PRR teams flexibility in the definition of low, medium, and high risk, the risk rating thresholds are configurable.  Again, the user editable fields on this tab are colored light yellow. The probabilities shown down the leftmost column represent what is selectable on the individual spreadsheets.  The consequence characterizations across the top are the available set of consequences on the individual spreadsheets.

Users may adjust risk sensitivity by entering different values in the two light yellow cells.  The tool enforces logical minimum and maximum values.  For example, the range of possible values for Low Risk upper threshold is between 0 and 4.  The range of possible values for the Medium Risk upper threshold is the Low Risk upper threshold and 4.

Note: The tool will check new user entries for validity, but does not dynamically check existing entries for validity.  For example, if the Low Risk upper threshold is change from 2 to 3 (allowable), while the Medium Risk upper threshold remains unchanged at 2, no error will be displayed.  However, when a user attempts to subsequently change the Medium Risk upper threshold value, the validation check will be employed.

These thresholds, once set, are used throughout the remaining spreadsheets to characterize the risk associated with each Evaluation Element and Sub Element.  The risk assessment for the Sub Element is a mathematical roll-up of the probabilities and consequences associated with each of the Evaluation Elements (described in greater detail in Section 3.4). 

3.4 Major Elements Tabs

These tabs have been created to capture PRR results.  Users can enter brief comments and select for each Evaluation Element an assessment of the probability of a bad result occurring because of the contractor’s implementation (or lack, thereof) of the Evaluation Element, and a consequence if the bad result does actually occur. The probability and impact fields should be selected from the drop-down lists provided.  Anything else will result in an error message.  Once selected, the risk will be calculated and presented according to the thresholds established by the PRR team on the Risk Threshold Tab.

Usability Tip: To select a probability or impact from the drop-down menus using the keyboard instead of the mouse, hold down the ALT key and press either the up or down arrow key.  The drop-down selection box will become available.  Use the up and down keys to highlight the desired value, and then press Enter to select.

Usability Tip: For ease of navigation, highlight rows 1 through 14 of each Major Element Tab, and set the View -> Zoom … ratio to “fit selection”.  The user can then move between each Sub Element by employing the Page Up and Page Down keys.

3.4.1 Sub Element and Evaluation Element Customization

Teams may wish to customize their Sub Elements or Evaluation Elements.  Sub Element Titles recorded on the Major Elements Tabs are automatically reflected on the Admin Tab.  Specific Evaluation Elements may be added, edited, or discarded.  

Modification of the Sub Element Titles and Evaluation Elements requires the sheets to be unprotected (see Section 3.1).  Sheet protection is revoked by selecting Tools -> Protection -> Unprotect Sheet.  Once the sheet has been unprotected, Sub Element Titles and Evaluation Element text may be customized. New Evaluation Elements may be added, up to the limits imposed by the tool’s design (e.g., 10 Evaluation Elements per Sub Element, 100 total Evaluation Elements for each Major Element).  Ten Evaluation Elements should be ample for most Sub Elements.  If more Evaluation Elements are needed for any given Sub Element, consider splitting the single Sub Element into two logical Sub Elements, if possible.  Alternatively, identify that the following page is “continued”.

Useful Feature: One particularly useful function has been occasionally employed.  By taking advantage of Excel’s “CONCATENATE” function, the Government PMO, Contractor, and Product entries carry forward to questions presented on subsequent tabs, where applicable.  For example, Major Element 1, Sub Element 1, Evaluation Element 1 states:
“Provide a company description. Include size, products, business base, and five-year business projection. Show F-15 as a percentage of total sales.”  

The text “F-15” was carried from the Product entry on the Admin Tab (cell C4) to the Evaluation Element.

The general syntax for producing such a result is as follows: 

=CONCATENATE(“Text String”,Cell Reference,”Text String”)

The specific syntax to produce the above example is as follows: 

=CONCATENATE("Provide a company description. Include size, products, business base, and five-year business projection. Show ",Admin!$C$4," as a percentage of total sales.")

Note that the parentheses establish the boundary for the CONCATENATE function.  Text to be presented as typed by the user are included within quotes.  Cell references containing data to be embedded within the text are delimited between commas.  The result is a sentence that appears to seamlessly combine the text with the referenced cell contents.  Multiple cell references can be embedded between multiple text strings to produce more elaborate results.  

3.4.2 Risk Calculations

Risk calculations occur within the Major Element Tabs in two hidden columns, Column H and Column I.  Column H translates the impact assessment (Column G) into a numerical score according to the following rules:

	If  The Impact Assessment Is
	Then The Impact # Is

	None
	0

	Insignificant
	1

	Minor
	2

	Major
	3

	Catastrophic
	4


Column I calculates a risk score by calculating the product of the probability assessment (Column F) and the Impact # (Column H). For example, if the probability assessment for a given Evaluation Element is 70%, and the associated Impact Assessment is Major, the calculated risk score would be 0.70 * 3 = 2.1. The result is compared to the threshold values entered by the PRR team on the Risk Thresholds Tab and the appropriate risk assessment is presented (Column J).

An overall risk assessment is calculated for each Sub Element, which is simply the mathematical average of all of the Sub Element’s individual Evaluation Elements (blank Evaluation Element rows are not factored into the calculation of the Sub Element average).  This is a controversial approach; some have argued that if any Evaluation Element within a Sub Element is high risk, then the entire Sub Element should also be rated as high risk.  The counter to this argument is that the concept could itself be taken to its extreme.  For example, if any Evaluation Element rated high risk necessitates the Sub Element as high risk, then the Major Element would have to be rated high risk because a Sub Element is high risk, and ultimately the entire PRR would have to be rated high risk since a Major Element is high risk.  Since all data is available for review, rolling up the risk assessment for summary and out-brief purposes appears to be a reasonable approach, but each PRR team should consider whether or not they wish to accept this approach.

3.4.3 Printing Sub Elements

The print settings on the pages have been set to allow 1 Sub Element per page.  In fact, if on a given page, the user elects “print preview”, the pages will be presented in such a way to support an out-brief.  Elect to print them, and the pages print nicely as a handout.

3.5 Summary Tab

The calculated average risk assessments for each Sub Element are carried forward from the Major Element Tabs to the Summary Tab.  This tab provides a single page view of the PRR outcome.

Useful Feature: When the PRR data has been captured by the PRR teams and the assessments are complete, the workbook has been designed for convenient printing or projection (e.g., on a screen for the PRR out-brief).  First, select all workbook tabs. Clicking on the Admin Tab, holding down the SHIFT key, and then clicking on the Summary Tab accomplishes this.  Then press the print preview button.  The Page Up and Page Down buttons can now be used to move from one screen to the next in support of an out briefing.   Or, if you like what you see, you can send the output to a printer to create a report or handouts!

3.6 PRR Tool Point of Contact

Questions or comments concerning the use or improvement of this tool can be forwarded to the attention of:

David Karr 

ASC/ENSM 

2530 Loop Road West 

Wright-Patterson Air Force Base, OH 45433-7101 

Phone: (937) 255-9581
David.Karr@wpafb.af.mil

4. Glossary

	Term
	Description

	Evaluation Element
	The lowest level of evaluation criteria.  Evaluation Elements are specific prompts for PRR participants that aid in the conduct of the PRR interviews.

	Major Element
	The highest level roll-up of evaluation elements.  The PRR Tool makes use of four Major Elements: Manufacturing Management, Manufacturing Engineering, Manufacturing Operations, and Product Assurance.

	Manufacturing Engineering

	This major element addresses “Producibility Assurance”.  Its focus is on how the product has been designed for producibility, and what planning has been accomplished to ensure methods, processes, and test equipment has been defined and are available to support manufacturing operations. 

	Manufacturing Management

	This major element addresses “Organizational Assurance”.  Its focus is on how well the manufacturing organization is structured and managed.  

	Manufacturing Operations

	This major element addresses “Process Assurance”.  It focuses on how manufacturing/production will be planned and executed.

	Product Assurance
	This major element addresses how quality has been designed into the product and how product quality will be pursued and verified.

	Sub Element
	First level roll-up of evaluation elements.  Sub Elements help individual PRR teams organize Evaluation Elements into related categories.
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